Author Topic: Pi Stomp with Hotspot  (Read 1608 times)

Peetem

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Pi Stomp with Hotspot
« on: November 21, 2023, 10:21:33 AM »
So I've tried everything and can't get the Pi Stomp hotspot to work.

My Mac and iPhone/iPad all see the Stomp, but when I try to connect I get a message back that I can't.  I'm 10)% positive I'm using the correct password. 

Any chance there's a problem with the Rasp Pi?  I don't mind buying a new Rasp Pi 3 A+, but can't think of anything else that could be the problem.

Thoughts?

Peetem

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #1 on: November 22, 2023, 10:24:30 AM »
Could someone post the contents of their hostapd.conf file?

Thanks!

micahvdm

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #2 on: November 23, 2023, 12:44:50 AM »
Could you try changing the channel in you hostapd file and see if this resolves you issue?

Peetem

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #3 on: November 23, 2023, 10:29:46 AM »
Could you try changing the channel in you hostapd file and see if this resolves you issue?

I'll give it a shot.  Good thinking.

Peetem

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #4 on: November 23, 2023, 10:41:06 AM »
No luck.

Same message "Unable to Join Network Pi-Stomp".  :(

micahvdm

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #5 on: November 24, 2023, 12:43:34 AM »
Hmmm…so what password are you using?

Peetem

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #6 on: November 24, 2023, 07:30:44 AM »
Hmmm…so what password are you using?

The password works - if I enter the wrong password, I get back a message that the password is incorrect and am prompted to re-enter.

When I use the correct password I simply get back the message "Unable to join network."

That's why I think there must be something wrong with my hostapd.conf file configuration.  But there are so many possible settings, I have no idea where to start.  So I was hoping someone could post their file (minus network name and password details of course).

Peetem

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #7 on: November 26, 2023, 03:51:01 PM »
I checked my hosted.conf file and it matches the default perfectly.

I have also checked the password and its 100% correct.

What's the possibility the problem is with the Raspberry Pi itself?

I have a space Pi (3A+) and can swap it out, but don't want to do that unless there's no other option.

Peetem

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #8 on: December 03, 2023, 12:09:35 AM »
Swapped out the Raspberry pi.

Same problem.

Can see the pi stomp as a hotspot, but cannot connect.  Password is correct.

I'm dumbfounded.

leftwing

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #9 on: December 03, 2023, 05:27:52 PM »
Had some trouble with apples devices too. sometimes need few tries to connect. but no single problem with android or pc.

Randall (Admin)

  • Administrator
  • Full Member
  • *****
  • Posts: 221
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #10 on: December 03, 2023, 06:14:59 PM »
Here is the contents of my hostapd.conf file which I just used to toggle between hotspot and wifi a few times:

pistomp@pistomp:~ $ more /etc/hostapd/hostapd.conf
# This is the name of the WiFi interface we configured above
interface=wlan0

# Use the nl80211 driver with the brcmfmac driver
driver=nl80211

# This is the name of the network
ssid=pistomp

# Use the 2.4GHz band
hw_mode=g

# Use channel 6
channel=6

# Enable 802.11n
ieee80211n=1

# Enable WMM
wmm_enabled=1

# Enable 40MHz channels with 20ns guard interval
ht_capab=[HT40][SHORT-GI-20][DSSS_CCK-40]

# Accept all MAC addresses
macaddr_acl=0

# Use WPA authentication
auth_algs=1

# Require clients to know the network name
ignore_broadcast_ssid=0

# Use WPA2
wpa=2

# Use a pre-shared key
wpa_key_mgmt=WPA-PSK

# The network passphrase
wpa_passphrase=pistompwifi

# Use AES, instead of TKIP
rsn_pairwise=CCMP

Peetem

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: Pi Stomp with Hotspot
« Reply #11 on: January 31, 2024, 08:04:01 AM »
So I took a look again at the hostapd.conf file....

It looked like there was a typo and a 0 was an "O".  I changed it, and then changed it back as it wasn't a typo - my old eyes saw the character incorrectly.

Saved the file on exit, but no changes were made.

Now the hotspot feature works!

No idea why, but I'll take it.  ;)